code format option causes header file reordering.

Comments

1 comment

  • Avatar
    Jon Elliott

    Hi Mark,

    To disable include sorting, set the Text Editor > Formatting > Sort Includes environment option to No.

    If you want to keep include sorting enabled but have a source file that requires a specific include order, add a line break or comment between the includes. For example:

    #include <stdint.h>
    #include <stddef.h>
    // Must come after stdint.h
    #include "myheader.h"

    Regards,

    Jon

    0
    Comment actions Permalink

Please sign in to leave a comment.