ST-Link/V2 and Mac OS Issue

Comments

16 comments

  • Avatar
    Michael Johnson

    I think the STM32VL Discovery Board has an original STLink on it. This requires STLinkUSBDriver.dll - an ST supplied file that is/was windows only.

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    If I disconnect the st-link and hook up the cross connect and swd board it should work?

     

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Not something I've tried - do a web search to see if anyone has used an external jtag cable on this board.

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    What would be a good Arm board like the discovery series which will work with cross connect and SWD board out of the box?  Would save me a lot of messing about!

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Any other ST board with the STLink/V2 is a good target - but they don't have external debug connectors. Most of the other manufacturers have both an onboard debug capability and an external debug connector.

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    I'll try and hook up the Jtag and let you know how it goes in case fyi

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    No luck with tag just getting memory write operation timed out?

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Did the connect work?

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    Yes got this message

     

    Connecting ‘CrossConnect for ARM’ using ‘030018a2’ completed

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Do you have the STM32VL Discovery board examples solution loaded?

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    Yes a set a project up with them

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Does the debugger identify the target?

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    Don't think so I just get the msg "Connecting ‘CrossConnect for ARM’ using ‘030018a2’ completed then a msg with a write time out?

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Did you connect up the VREF?

    0
    Comment actions Permalink
  • Avatar
    Adam Thompson

    Yes tied it to 3V3 with Supply P1 and P2 on crossConnect

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    What's the NSRST pin doing?

    0
    Comment actions Permalink

Please sign in to leave a comment.