watch window double precision vars shown as single precision LPC1768

Comments

2 comments

  • Avatar
    Michael Johnson

    Do you have "Treat double as float" set to "yes"?

    0
    Comment actions Permalink
  • Avatar
    Mark Boyce

    No, but I just found a section under Tools->Options->Debugging->Display Options->Display Floating Point Number In which was set to  %.8g

    I've now set it to %.12g and it's now working for me.

     

    Thanks

    0
    Comment actions Permalink

Please sign in to leave a comment.