strange editor auto-replacements

Comments

4 comments

  • Avatar
    Dr Danish Ali

    Crossworks for Arm 2.3.0.2012111600.16701 has an option

    Tools : Options... : Text Editor : Auto-Surround Text

    Setting this to "Disabled" seems to solve this annoying behaviour.

    0
    Comment actions Permalink
  • Avatar
    frank meyer

    I would try that, if only I had this option. I have V2.2, so this seems new in V2.3.

    Is there anything else that would suggest to update ? There is not so much to complain, except possibly the meagre stacksize default settings ...

    0
    Comment actions Permalink
  • Avatar
    Dr Danish Ali

    I can't think of any reason not to update. You can keep both on your machine.

    (As far as I know you don't have to pay to go from 2.x to 2.y).

    I didn't spot this change in the release notes, and it was only your comment that prompted me to look again for an option. I had been cursing the "feature" ever since I paid to upgrade from 1.7 to 2.2 (which I need because one upcoming project is likely to involve an stm32f4xx). But then I found a bug where certain files were not being rebuilt when project options were changed which Rowley fixed for 2.3.

    0
    Comment actions Permalink
  • Avatar
    frank meyer

    I can't think of any reason not to update.

    That sounds like from a salesman  ;-)

    But honestly, I guess there needs to be a certain level of suffering required for a desire to update. Like from Windows3.0 to Windows3.1, or so ...

    And that level is not reached for me by far. Having to deal with MPLabX for PIC18 (a NetBeans-based IDE for/from Microchip) in my day job, working with CrossWorks is a breeze for me. Well, except of those small editor annoyances.  Having once started with Z80 and CP/M, I can't get use to editors that try to be smarter than me.

    For an update, I'm going to check the release notes, maybe it's worthwile. Even using a private licence, I'd avoid changing a running system.

    0
    Comment actions Permalink

Please sign in to leave a comment.