"Optimize for size"

Comments

4 comments

  • Avatar
    Michael Johnson

    Did you try setting the "Enable Printf"/"Enable Scanf"/"Enable DebugIO" to be "No"

    0
    Comment actions Permalink
  • Avatar
    Henry

    Hello Michael,

    now  that I set Printf Supported, Scanf Supported and DebugIO Supported  to NO the file has been considerable reduced to 3971 bytes (3887 before). That solved my problem. Thanks for that very fast response! Rowley`s support is really excellent.

    What still surprised me a bit is that the file generated with

    THUMB Flash Release (4047 Bytes) is bigger than that generated with THUM Flash Debug (3971 Bytes). I would have expected it the other way round.

    Regards,

    Henry

    0
    Comment actions Permalink
  • Avatar
    Henry

    Perhaps this is the explanation for different file sizes:

    I first set Printf Supported and Scanf Supported to NO and compiled the project. The file then was still too big. In a second step I set DebugIO Supported to NO and got a file size < 4k, but with different sizes for both configurations. As I did not modify any file between those 2 steps, I suppose that the object files have not been rebuilt. Would that be a possible reason?

    When I applied the new property settings to the original project from the archive, the resulting file size for debug and release configuration were the same.

    Henry

    0
    Comment actions Permalink
  • Avatar
    Michael Johnson

    Hi Henry,

    Ensure that you've set the properties in the Common configuration. The property display in the project explorer is my preferred way of seeing what properties are set in what configurations.

    Regards

    Michael

    0
    Comment actions Permalink

Please sign in to leave a comment.