Migration to Windows 7 .. cpu support packages

Comments

2 comments

  • Avatar
    Jon Elliott

    It sounds like you have an absolute path somewhere in your project, the easiest thing to do is open up the .hzp file in a text editor and look for the path. The macros $(PackagesDir) or $(TargetsDir) should be used to reference the packages and targets directory rather than using an absolute path.

    You wouldn't normally edit the files in the packages directory, the intention is that if you need to modify any system files you would import them locally into your project (right click on file in project explorer and click Import) and then edit them.

    Having said that, you can change the location of the packages directory by clicking Tools > Options and setting Environment > Directory Options > Package Directory.

    0
    Comment actions Permalink
  • Avatar
    Gordon Scott

    Hi Jon,

    I tried looking though the .hzp and .hzs files, but the path wasn't there. I tried grepping every file in the project for "Documents", found some in the build directories, so I just deleted the lot from there and started a rebuild, though as a work-in-progtress, currently I have some errors to sort.

    However .. compiling just STM32F10x_ctl.c fixes that problem. Closer inspection reveals that the absolute path is embedded in both the .d and .o files, and that is from where the IDE gets its path to the source.

     

    I tried setting the Package Directory to a UNC name:

    • //cilserver20/users/gordon/CrossWorks_Packages/CrossWorks for ARM/packages

    But it's rather confused about that:

    • U:/cilserver20/users/gordon/CrossWorks_Packages/CrossWorks for ARM/packages/targets/ST_STM32F10x/STM32F10x_ctl.c: No such file or directory

    Using the mapped drive sorts it out, so I guess I'll need sort out a map directory for CrosswWorks. Well, I'd been thinking it was time softwaere was centralised, anyway.

    0
    Comment actions Permalink

Please sign in to leave a comment.